Articles

April 13, 2012 -- Apple recently released corrected the issues with Safari and the Internet banking site.  You need to update to their latest versions of their web browser, Safari 5.1.7.

The changes in Safari 5.1.4 and 5.1.5 were impacting our internet banking site and the ability to access many other types of websites.  Apple made the fix to version 5.1.7

If you are having trouble with your Safari browser:

 

  • Update to the lastest version of Safari at least 5.1.7

 

Supported Browsers

Having access to the internet is the first step towards online banking. The next step requires you download a web browsers software that is supported and works with our online banking system.

Supported Web Browsers (Software)

Web BrowserPC VersionMac VersionDownload
Microsoft Internet Explorer (IE) Version 7.0-8.0*

Version 9.0
[Not Available]Internet Exlporer
download
FirefoxVersion 3.0 and higherFirefox
download
Firefox
download
Safari[Not Available]Version 4.0 and higherSafari
download


*NOTE: As of April 8, 2010, Internet Explorer versions older than version 6.0 are not valid for access to online banking. Microsoft no longer supports these versions and security updates are not available. Users attempting to access online banking with a version of IE older than 6.0 will be denied access.

What types of internet browsers can I use to access my accounts online?
Use one of the browsers compatible with your computer whether PC or Mac listed above. If you don't have one current, download the latest version using the linked icons listed.

What if I am not using one of the supported browsers?
You may experience issues with online banking. If this occurs, please download one of the browsers listed and attempt the action again. Links to download the browsers are above.

Can I use a beta version of one of the browsers above?
We do not recommend using a Beta version of any browser. When new versions of browsers are fully tested and deemed compatible with online banking, they will be updated on the supported browsers list.

Not Recommended or Unsupported Web Browsers

The following types of browsers and tools are not recommended or supported with our online banking site:

  • Embedded Browsers contained within personal or commercial financial management software (Quicken, Quickbooks, Money, etc.)
  • Browser add-ins and toolbars (IE 7 Pro, Google, Yahoo, etc.)

If you are using a non-supported browser, an embedded browser or a browser add-in, you may experience functionality issues with online banking. If this occurs, please download one of the browsers listed above or remove the add-in and attempt the action again.

If you continue to have difficulties, please contact our Customer Support team at 269 349 0100